Skip to main content
VulnerabilityPublished

CVE-2026-26961: ruby-rack vulnerabilities

Affects ruby-rackSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade to 3.2.4-1ubuntu1.1 soon.

Data as of 4 Nov 2026, 04:01 UTC

Severity
High

Rated High by Threat Radar's AI analysis · CVSS not yet scored by NVD

Patch
Available – fixed in 3.2.4-1ubuntu1.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu ruby-rack package to 3.2.4-1ubuntu1.1.

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTSruby-rackpkg:deb/ubuntu/ruby-rack?arch=source&distro=resoluteOther threatsAffected
  • <3.2.4-1ubuntu1.1
Fixed in
  • 3.2.4-1ubuntu1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied by updating to ruby-rack version 3.2.4-1ubuntu1.1 as provided by the Ubuntu security notice USN-8989-1. After updating, any applications using Rack must be restarted to apply the fixes. No additional mitigation actions are required beyond applying the official update.

Description

Multiple vulnerabilities were discovered in the Ruby Rack webserver interface affecting header parsing, regular expressions, static file handling, and resource consumption. These issues could allow attackers to bypass security filters, cause denial of service through excessive CPU or disk usage, manipulate header values, exfiltrate data, disclose deployment details, or poison generated links. The vulnerabilities are addressed in the updated package version 3.2.4-1ubuntu1.1.

References

Community reviews

Loading reviews…