CVE-2025-61594: Ruby2.3 · In versions prior to 0.12.5, 0.13.3, and 1.0.4, a bypass exists for the fix to
Affects ruby2.3Source GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 2.1 Low · fixed in 2.3.1-2~ubuntu16.04.16+esm12 : update ruby2.3 when convenient.
Data as of 27 Oct 2026, 06:42 UTC
- Patch
- Available – fixed in 2.3.1-2~ubuntu16.04.16+esm12, 2.5.1-1ubuntu1.16+esm7, 2.7.0-5ubuntu1.18+esm4 +3
CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10ruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10ruby3.3pkg:deb/ubuntu/ruby3.3?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSruby3.2pkg:deb/ubuntu/ruby3.2?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSruby3.0pkg:deb/ubuntu/ruby3.0?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSruby2.7pkg:deb/ubuntu/ruby2.7?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
URI is a module providing classes to handle Uniform Resource Identifiers. In versions prior to 0.12.5, 0.13.3, and 1.0.4, a bypass exists for the fix to CVE-2025-27221 that can expose user credentials. When using the `+` operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. Versions 0.12.5, 0.13.3, and 1.0.4 fix the issue.
References
- ubuntu.com/security/CVE-2025-61594 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2025-61594 (opens in a new tab)
- ruby-lang.org/en/news/2025/10/07/uri-cve-2025-61594/ (opens in a new tab)
- github.com/ruby/uri/commit/20157e3e29b125ff41f1d9662e2e3b1d066f5902 (opens in a new tab)
- github.com/ruby/uri/commit/7e521b2da0833d964aab43019e735aea674e1c2c (opens in a new tab)
- github.com/ruby/uri/commit/d3116ca66a3b1c97dc7577f9d2d6e353f391cd6a (opens in a new tab)
- github.com/rubysec/ruby-advisory-db/blob/master/gems/uri/CVE-2025-61594.yml (opens in a new tab)
- ubuntu.com/security/notices/USN-8137-1 (opens in a new tab)