Skip to main content
VulnerabilityPublished Updated

CVE-2026-29090: Rucio Has SQL Injection

Affects rucioSource GCVE Database

0
Compare
Authoritative record:CVE-2026-29090· Critical 9.0

Not known to be exploited · CVSS 9.0 Critical : upgrade to 35.8.5 as a priority.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 35.8.5, 38.5.5, 39.4.2 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
PyPIrucioAffected
  • >=1.30.0 <35.8.5
Fixed in
  • 35.8.5
PyPIrucioAffected
  • >=36.0.0 <38.5.5
Fixed in
  • 38.5.5
PyPIrucioAffected
  • >=39.0.0 <39.4.2
Fixed in
  • 39.4.2
PyPIrucioAffected
  • >=40.0.0 <40.1.1
Fixed in
  • 40.1.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid enabling or disable the postgres_meta metadata plugin if possible. Restrict access to the DID search API to trusted users only.

Description

Rucio contains a critical SQL injection vulnerability in the FilterEngine PostgreSQL query builder used by the DID search API when the postgres_meta plugin is configured. Authenticated users can inject arbitrary SQL via filter keys and values that are unsafely interpolated into raw SQL statements. This allows full database compromise including data exfiltration, modification, and potential remote code execution. The vulnerability arises from direct string formatting of attacker-controlled input without proper sanitization or parameterization. Exploitation requires the postgres_meta plugin to be explicitly enabled and valid user authentication.

References

Community reviews

Loading reviews…