Skip to main content
CVE-2026-115909VulnerabilityPublished Updated

Rust zip: From 1.3.0 until 9.0.0, ZipArchive::extract in src/read/mod.rs calls Vec::with_capacity for a symbolic link

Affects rust-zipSource GCVE Database

0
Authoritative record:CVE-2026-115909· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in 9.0.0 : patch rust-zip soon.

Data as of 28 Oct 2026, 22:41 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 9.0.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10rust-zippkg:deb/ubuntu/rust-zip?arch=source&distro=stonkingOther threatsAffected
  • =5.1.1-3
  • =5.1.1+dfsg-1
Fixed in–
Ubuntu 26.04 LTSrust-zippkg:deb/ubuntu/rust-zip?arch=source&distro=resoluteOther threatsAffected
  • =2.5.0-1
  • =5.1.1-2
  • =5.1.1-3
Fixed in–
Ubuntu 24.04 LTSrust-zippkg:deb/ubuntu/rust-zip?arch=source&distro=nobleOther threatsAffected
  • =0.6.6-1
  • =0.6.6-2
Fixed in–
Ubuntu 22.04 LTSrust-zippkg:deb/ubuntu/rust-zip?arch=source&distro=jammyOther threatsAffected
  • =0.5.8-2
  • =0.5.13-1
Fixed in–
Ubuntu 20.04 LTSrust-zippkg:deb/ubuntu/rust-zip?arch=source&distro=focalOther threatsAffected
  • =0.5.0-1
  • =0.5.3-1
  • =0.5.3-2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade rust-zip to version 9.0.0 or later, where this issue is fixed. No other mitigations are indicated or effective since the abort cannot be caught or contained.

Description

A denial of service vulnerability exists in the rust-zip library versions from 1.3.0 up to but not including 9.0.0. The ZipArchive::extract function improperly uses an attacker-controlled ZIP64 uncompressed_size value to allocate memory, which can cause the process to abort before validating the entry. This abort cannot be caught or contained, allowing repeated denial of service attacks. The issue is fixed in version 9.0.0.

References

Community reviews

Loading reviews…