Skip to main content
CVE-2026-54789VulnerabilityPublished Updated

SUSE · security update for mod_auth_openidc

Affects SUSESource GCVE Database

0
Compare
Authoritative record:CVE-2026-54789· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade SUSE mod_auth_openidc to 2.4.19.4 soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.19.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade mod_auth_openidc and openidc/mod_auth_openidc to 2.4.19.4.

Affected software

ProductAffectedFixed in
OpenIDCmod_auth_openidcAffected
  • <2.4.19.4
Fixed in
  • 2.4.19.4
GitHubopenidc/mod_auth_openidcpkg:github/openidc/mod_auth_openidcOther threatsAffected
  • <2.4.19.4
Fixed in
  • 2.4.19.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released security updates that fix this vulnerability. Users should apply the updated mod_auth_openidc packages provided in Red Hat Enterprise Linux 9.4 and 10 as detailed in the Red Hat advisory RHSA-2026:69718. Refer to https://access.redhat.com/articles/11258 for update instructions. No additional mitigation is required beyond applying the official patches.

Description

A denial of service vulnerability exists in the mod_auth_openidc module for Apache HTTP Server due to malformed state cookie parsing. This module enables Apache to function as an OpenID Connect Relying Party or OAuth 2.0 Resource Server. The vulnerability is identified as CVE-2026-54789 and affects certain versions of mod_auth_openidc distributed with Red Hat Enterprise Linux 9.4 and 10. A security update addressing this issue has been released by Red Hat.

References

Community reviews

Loading reviews…