SUSE beets · Security update for beets
Affects SUSE beetsSource GCVE Database
Not known to be exploited · CVSS 6.0 Medium : upgrade SUSE beets to 2.10.0 when convenient.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 22% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.10.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:N/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade beets to 2.10.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPIbeetspkg:pypi/beetsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade beets to version 2.10.0 or later, where this vulnerability is fixed. No other mitigation steps are indicated.
Description
A security update for the beets software addresses a vulnerability identified as CVE-2026-42052. Prior to version 2.10.0, the bundled web UI of beets uses Underscore template interpolation mode <%= ... %> for untrusted metadata fields, which can lead to security issues. This vulnerability is rated medium severity.