Skip to main content
CVE-2026-24515VulnerabilityPublished Updated

SUSE · Security update for expat

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-24515· Low 2.9

Not known to be exploited · CVSS 2.9 Low : upgrade SUSE libexpat to 2.7.4 when convenient.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 3.1 base score
2.9Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.7.4
CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade libexpat and libexpat/libexpat to 2.7.4.

Affected software

ProductAffectedFixed in
libexpat projectlibexpatAffected
  • <2.7.4
Fixed in
  • 2.7.4
GitHublibexpat/libexpatpkg:github/libexpat/libexpatOther threatsAffected
  • <2.7.4
Fixed in
  • 2.7.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update has been released by the SUSE Product Security Team that fixes these vulnerabilities. Users should apply the update to expat version 2.7.1-160000.4.1 on affected architectures (aarch64, ppc64le) to remediate these issues. No additional mitigation steps are indicated.

Description

This security update for expat addresses two vulnerabilities: CVE-2026-24515, a NULL dereference caused by failure to copy encoding handler data, and CVE-2026-25210, an integer overflow due to lack of buffer size checking. Both vulnerabilities could lead to stability or security issues in affected systems. The update fixes these issues to improve software reliability and security.

References

Community reviews

Loading reviews…