SUSE gleam · Security update for gleam
Affects SUSE gleamSource GCVE Database
Not known to be exploited · CVSS 7.6 High · fixed in SUSE package updates : patch SUSE gleam soon.
Data as of 1 Nov 2026, 11:03 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 7% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.18.1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Hexgleampkg:hex/gleamOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade to Gleam version 1.18.1 or later, which includes the fix for CVE-2026-59247. The update also requires Erlang version 26 or higher. No other mitigation steps are indicated by the vendor advisory.
Description
A security update for Gleam version 1.18.1 addresses a vulnerability (CVE-2026-59247) involving insufficient verification of data authenticity. This flaw could allow a man-in-the-middle (MITM) attacker to substitute forged Hex package contents during dependency resolution. The update also sets the minimum required Erlang version to 26 and includes various bug fixes and performance improvements.