Skip to main content
CVE-2026-34379VulnerabilityPublished Updated

SUSE · Security update for openexr

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-34379· High 7.1

Not known to be exploited · CVSS 7.1 High · fixed in SUSE package updates : patch SUSE openexr soon.

Data as of 31 Oct 2026, 08:20 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.9, 3.3.9, 3.2.7
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade openexr and academysoftwarefoundation/openexr to 3.4.9, 3.3.9 or 3.2.7.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.9
Fixed in
  • 3.4.9
AcademySoftwareFoundationopenexrAffected
  • >=3.3.0 <3.3.9
Fixed in
  • 3.3.9
AcademySoftwareFoundationopenexrAffected
  • >=3.2.0 <3.2.7
Fixed in
  • 3.2.7
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • <3.2.7
  • <3.3.9
  • <3.4.9
Fixed in
  • 3.2.7
  • 3.3.9
  • 3.4.9

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update has been released by the SUSE Product Security Team addressing these vulnerabilities. Users should apply the official patches or updates provided by SUSE to remediate these issues. Patch status is not explicitly confirmed in the provided data; therefore, check the vendor advisory for current remediation guidance.

Description

Multiple security vulnerabilities have been identified in the openexr library affecting image decoding. These include misaligned memory writes causing denial of service, integer overflow risks, out-of-bounds read and write, and potential arbitrary code execution from crafted EXR files. The issues are addressed in a security update by the SUSE Product Security Team.

References

Community reviews

Loading reviews…