Skip to main content
CVE-2026-40244VulnerabilityPublished Updated

SUSE · Security update for openexr

Affects SUSESource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-40244· High 8.4

Not known to be exploited · CVSS 8.4 High · fixed in SUSE package updates : patch SUSE openexr soon.

Data as of 31 Oct 2026, 20:20 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.4.10, 3.3.10, 3.2.8
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.

What to do

Upgrade openexr to 3.4.10, 3.3.10 or 3.2.8.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.10
Fixed in
  • 3.4.10
AcademySoftwareFoundationopenexrAffected
  • >=3.3.0 <3.3.10
Fixed in
  • 3.3.10
AcademySoftwareFoundationopenexrAffected
  • >=3.2.0 <3.2.8
Fixed in
  • 3.2.8
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • 3.2.0 – 3.4.10
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update has been released by the SUSE Product Security Team to fix these vulnerabilities. Users should apply the update as provided by their SUSE distribution. Patch status is not explicitly confirmed in the provided data; users should consult the official SUSE advisory for detailed remediation instructions and affected versions.

Description

This security update for openexr addresses two integer overflow vulnerabilities related to pointer arithmetic in the DWA compression components. These vulnerabilities could potentially lead to memory corruption or other unintended behavior. The issues are identified as CVE-2026-40244 and CVE-2026-40250. No known exploits in the wild have been reported. The severity is assessed as high based on the nature of the vulnerabilities.

References

Community reviews

Loading reviews…