SUSE pgvector-devel · Security update for pgvector
Affects SUSE pgvector-develSource GCVE Database
Not known to be exploited · CVSS 8.1 High : upgrade the affected SUSE packages to 0.8.2 soon.
Data as of 31 Oct 2026, 20:20 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.8.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 25 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 31 Oct 2026.
What to do
Upgrade the SUSE to 0.8.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
SUSEsuse/pgvector-develpkg:rpm/suse/pgvector-develOther threats | Affected
| Fixed in
|
SUSEsuse/postgresql13-pgvectorpkg:rpm/suse/postgresql13-pgvectorOther threats | Affected
| Fixed in
|
SUSEsuse/postgresql14-pgvectorpkg:rpm/suse/postgresql14-pgvectorOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should update pgvector to version 0.8.2 or later to remediate this vulnerability. No other mitigation steps are indicated.
Description
A buffer overflow vulnerability (CVE-2026-3172) exists in the parallel HNSW index build of pgvector, fixed in version 0.8.2. This update also addresses issues with index searches in EXPLAIN output for Postgres 18.