Semantic MediaWiki from 4.2.0 before 7.3.1 contains a stored cross-site scripting vulnerability that allows
Source GCVE Database
Not known to be exploited · CVSS 4.8 Medium : upgrade to 7.3.1 when convenient.
Data as of 27 Oct 2026, 13:28 UTC
- Patch
- Available – fixed in 7.3.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:P/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 27 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade SemanticMediaWiki to 7.3.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SemanticMediaWikiSemanticMediaWiki | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version is available starting from Semantic MediaWiki 7.3.1. Users should upgrade to version 7.3.1 or later to remediate this vulnerability. Until patched, restrict profile and schema editing permissions to trusted users only.
Description
Semantic MediaWiki versions from 4.2.0 up to but not including 7.3.1 contain a stored cross-site scripting (XSS) vulnerability. This flaw allows authenticated users with profile or schema editing permissions to inject malicious HTML through FacetedSearch exploration-link labels. The injected markup is passed unescaped to the page rendering function, potentially enabling script execution in the browsers of users viewing the affected Special:FacetedSearch page.