Skip to main content
VulnerabilityPublished

semantic-router exposed to compromised litellm wheel (CVE-2026-42208) via unbounded transitive pin

Affects semantic-routerSource GCVE Database

0

Mentioned vulnerabilities

Severity
Critical

Rated by Threat Radar

Patch
Available – fixed in 0.1.15

Data as of 26 Jun 2026, 22:07 UTC

What to do

Upgrade semantic-router to 0.1.15.

Affected software

ProductAffectedFixed in
PyPIsemantic-routerAffected
  • >=0.1.8 <0.1.15
Fixed in
  • 0.1.15

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in semantic-router version 0.1.15, which raises the minimum litellm version to 1.83.7, avoiding the compromised 1.82.8 release. Users unable to upgrade immediately should explicitly pin litellm to versions >=1.83.7 and exclude 1.82.8. Additionally, audit site-packages directories for the presence of litellm_init.pth and remove it if found. Rotate any credentials that may have been exposed in environments where the affected versions were installed and run during the vulnerable window.

Description

semantic-router versions 0.1.8 through 0.1.14 declare a dependency on litellm with no upper bound, allowing resolution to a compromised litellm wheel version 1.82.8 during a specific time window. This malicious litellm wheel executes code on Python startup without import, exfiltrating sensitive credentials and secrets. The issue is fixed in semantic-router 0.1.15 by raising the minimum litellm version to 1.83.7. Users are advised to upgrade or explicitly pin litellm to safe versions and audit for malicious files.

References

Community reviews

Loading reviews…