semantic-router versions 0.1.8 through 0.1.14 declare a dependency on litellm with no upper bound, allowing resolution to a compromised litellm wheel version 1.82.8 during a specific time window. This malicious litellm wheel executes code on Python startup without import, exfiltrating sensitive credentials and secrets. The issue is fixed in semantic-router 0.1.15 by raising the minimum litellm version to 1.83.7. Users are advised to upgrade or explicitly pin litellm to safe versions and audit for malicious files.