Skip to main content
VulnerabilityPublished Updated

CVE-2024-22190: Snakemake · Untrusted search path under some conditions on Windows allows arbitrary code execution

Affects snakemakeSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 7.8 High : upgrade to 8.1.0_1 soon.

Data as of 1 Nov 2026, 22:57 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 24% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.1.0_1, 1.2.0.post0_14
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade snakemake to 8.1.0_1; legit to 1.2.0.post0_14.

Affected software

ProductAffectedFixed in
Homebrewsnakemakepkg:brew/snakemakeOther threatsAffected
  • >=5.5.3 <8.1.0_1
Fixed in
  • 8.1.0_1
Homebrewlegitpkg:brew/legitOther threatsAffected
  • <1.2.0.post0_14
Fixed in
  • 1.2.0.post0_14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users should upgrade Legit to a fixed version outside the affected ranges (versions >=5.5.3 <8.1.0_1 and <1.2.0.post0_14 are vulnerable). No vendor advisory content was provided to indicate otherwise, so applying the official patch or upgrade is recommended to remediate the issue.

Description

CVE-2024-22190 is a high-severity vulnerability in the Legit tool related to GitPython's handling of untrusted search paths on Windows. It allows arbitrary code execution if GitPython runs git commands through a shell or executes bash.exe to interpret hooks, potentially running malicious executables from untrusted repository directories. This vulnerability is a result of incomplete mitigation of a previous issue (CVE-2023-40590).

References

Community reviews

Loading reviews…