Skip to main content
VulnerabilityPublished Updated

CVE-2024-52804: Snakeviz · Tornado has an HTTP cookie parsing DoS vulnerability

Affects snakevizSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52804· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.2.2_1 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.2_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade snakeviz to 2.2.2_1.

Affected software

ProductAffectedFixed in
Homebrewsnakevizpkg:brew/snakevizOther threatsAffected
  • >=2.2.0 <2.2.2_1
Fixed in
  • 2.2.2_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the vulnerability is fixed in Snakeviz version 2.2.2_1. Users should upgrade to this version or later to remediate the issue. No additional mitigation steps are indicated.

Description

CVE-2024-52804 is a denial-of-service vulnerability in the HTTP cookie parsing algorithm of Snakeviz's Tornado component. Versions of Snakeviz from 2.2.0 up to but not including 2.2.2_1 are affected. The vulnerability arises from quadratic time complexity in cookie parsing, which can cause excessive CPU usage and block the event loop thread, impacting request processing.

References

Community reviews

Loading reviews…