Skip to main content
VulnerabilityPublished Updated

CVE-2025-47287: Snakeviz · Tornado vulnerable to excessive logging caused by malformed multipart form data

Affects snakevizSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 2.2.2_2 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.2_2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade snakeviz to 2.2.2_2.

Affected software

ProductAffectedFixed in
Homebrewsnakevizpkg:brew/snakevizOther threatsAffected
  • >=2.2.0 <2.2.2_2
Fixed in
  • 2.2.2_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade to Tornado version 6.5 or later, where this issue is fixed. Until the upgrade is possible, mitigate risk by blocking HTTP requests with the Content-Type header set to multipart/form-data at a proxy or firewall to prevent triggering the vulnerability.

Description

A denial-of-service vulnerability exists in Tornado's multipart/form-data parser prior to version 6.5. When encountering malformed multipart form data, the parser logs warnings synchronously while continuing to parse, allowing remote attackers to generate excessive logging and cause service disruption. The vulnerability is fixed in Tornado 6.5.

References

Community reviews

Loading reviews…