CVE-2025-67724: Snakeviz · Tornado vulnerable to Header Injection and XSS via reason argument
Affects snakevizSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 2.2.2_3 when convenient.
Data as of 30 Oct 2026, 06:59 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.2_3
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 12 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade snakeviz to 2.2.2_3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewsnakevizpkg:brew/snakevizOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade to Tornado version 6.5.3 or newer (Snakeviz 2.2.2_3 or later) to apply the official fix. Alternatively, avoid passing untrusted or user-controlled data to the `reason` argument. Since the `reason` argument is rarely required and not used in HTTP/2, it can generally be omitted. For custom error messages, use the `log_message` argument instead of `reason` to avoid injection risks.
Description
Tornado versions prior to 6.5.3 are vulnerable to header injection and reflected cross-site scripting (XSS) via the `reason` argument used in HTTP status lines. This vulnerability arises when untrusted input is passed to the `reason` argument in `RequestHandler.set_status` or `tornado.web.HTTPError`, leading to injection of malicious content in HTTP headers or the default error page. Exploitation requires an attacker to control the `reason` argument, typically through application logic that reflects user input. The vulnerability is fixed in Tornado 6.5.3 and later.
References
- github.com/tornadoweb/tornado/security/advisories/GHSA-pr2v-jx2c-wg9f (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-67724 (opens in a new tab)
- github.com/tornadoweb/tornado/commit/9c163aebeaad9e6e7d28bac1f33580eb00b0e421 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/tornado/PYSEC-2025-265.yaml (opens in a new tab)
- github.com/tornadoweb/tornado (opens in a new tab)
- github.com/tornadoweb/tornado/releases/tag/v6.5.3 (opens in a new tab)