SQLite before 3.53.2 contains memory corruption vulnerabilities in the FTS5 full-text search extension that allow
Affects sqliteSource GCVE Database
Not known to be exploited · CVSS 5.5 Medium · fixed in 3.37.2-2ubuntu0.6 : update sqlite when convenient.
Data as of 31 Oct 2026, 04:23 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 3.1 | 5.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 4.0 | 6.8 |
- Patch
- Available – fixed in 3.37.2-2ubuntu0.6, 3.45.1-1ubuntu2.6, 3.46.1-8ubuntu0.1 +1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 25.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSsqlitepkg:deb/ubuntu/sqlite?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official Ubuntu security updates that include fixed versions of the SQLite package. The fixed versions are 3.37.2-2ubuntu0.6, 3.45.1-1ubuntu2.6, 3.46.1-8ubuntu0.1, and 3.46.1-9ubuntu0.1 depending on the Ubuntu release. A standard system update will apply these fixes. No additional mitigation is required beyond updating to these patched versions.
Description
SQLite versions before 3.53.2 contain memory corruption vulnerabilities in the FTS5 full-text search extension. These flaws allow attackers to cause process crashes, memory exhaustion, or potentially execute arbitrary code by supplying a crafted database with malformed FTS5 page data. The vulnerabilities involve an out-of-bounds read and a heap buffer overflow triggered during FTS5 MATCH queries against malicious databases. Fixed versions are available in Ubuntu package updates.
References
- ubuntu.com/security/CVE-2026-11822 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-11822 (opens in a new tab)
- sqlite.org/releaselog/3_53_2.html (opens in a new tab)
- vulncheck.com/advisories/sqlite-before-memory-corruption-in-fts5-extension (opens in a new tab)
- ubuntu.com/security/notices/USN-8480-1 (opens in a new tab)