SQLite before 3.54.0 contains an authorization bypass vulnerability in lookupName() that invokes the authorizer only
Affects sqliteSource GCVE Database
Not known to be exploited · CVSS 2.0 Low.
Data as of 4 Nov 2026, 10:58 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.0 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 2.5 |
| CNA | CVSS 4.0 | 2.0 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10sqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlitepkg:deb/ubuntu/sqlite?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSsqlite3pkg:deb/ubuntu/sqlite3?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade SQLite to version 3.54.0 or later where this vulnerability is fixed. No other specific mitigations are indicated. Since this is a local attack requiring SQL submission capability, restricting untrusted SQL input is also advisable.
Description
SQLite versions before 3.54.0 have an authorization bypass vulnerability in the lookupName() function. This flaw causes the authorizer callback to be invoked only for the first joined table's USING column, allowing attackers who can submit SQL queries to bypass SQLITE_READ restrictions on shared USING columns in RIGHT or FULL JOIN operations.
References
- ubuntu.com/security/CVE-2026-119377 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119377 (opens in a new tab)
- sqlite.org/bugs/info/2026-07-05T08:15:45Z (opens in a new tab)
- sqlite.org/src/info/bbd69ce274620008 (opens in a new tab)
- sqlite.org/src/info/2cb22877683680c1 (opens in a new tab)
- abraxaslabs.tech/research/sqlite-fj-using-auth (opens in a new tab)
- github.com/sqlite/sqlite (opens in a new tab)
- github.com/sqlite/sqlite/blob/version-3.53.4/src/resolve.c (opens in a new tab)
- github.com/sqlite/sqlite/commit/5694c3bb2a6a40770ecd2f65910eea756734dfd8 (opens in a new tab)
- github.com/sqlite/sqlite/commit/7ff247c5b9ead3ad8a69c26d3fd264878e127237 (opens in a new tab)
- sqlite.org/releaselog/3_54_0.html (opens in a new tab)
- vulncheck.com/advisories/sqlite-before-3.54.0-authorizer-bypass-via-right-or-full-join-using (opens in a new tab)