Skip to main content
VulnerabilityPublished

CVE-2026-61642: squid security update

Affects squidSource GCVE Database

0
Compare
Authoritative record:CVE-2026-61642· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade to 6.6-10.oe2403sp3 soon.

Data as of 29 Oct 2026, 11:02 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.6-10.oe2403sp3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade squid to 6.6-10.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3squidpkg:rpm/openEuler/squid&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <6.6-10.oe2403sp3
Fixed in
  • 6.6-10.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in Squid version 6.6-10.oe2403sp3. Users should upgrade to this version or later to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Squid proxy server versions prior to 6.6-10.oe2403sp3 are vulnerable to an HTTP Request Smuggling attack due to improper enforcement of HTTP/1.1 Transfer-Encoding header parsing. This flaw allows a trusted client to bypass security mechanisms and potentially poison upstream HTTP caches by injecting malicious content. The issue is fixed in version 6.6-10.oe2403sp3.

References

Community reviews

Loading reviews…