CVE-2026-61642: squid security update
Affects squidSource GCVE Database
Not known to be exploited · CVSS 7.7 High : upgrade to 6.6-10.oe2403sp1 soon.
Data as of 29 Oct 2026, 11:03 UTC
- EPSS
- 2.2% chance of exploitation in 30 days – higher than 82% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.6-10.oe2403sp1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade squid to 6.6-10.oe2403sp1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
openEuler 24.03-LTS-SP1squidpkg:rpm/openEuler/squid&distro=openEuler-24.03-LTS-SP1Other threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security fix is available in Squid version 7.6. Users should upgrade to version 7.6 or later to remediate this vulnerability. No other mitigation steps are indicated by the vendor advisory.
Description
Squid proxy server versions from 3.3.0.1 up to but not including 7.6 are vulnerable to an HTTP Request Smuggling attack due to improper enforcement of HTTP/1.1 Transfer-Encoding header parsing. This flaw allows a trusted client to bypass security controls and potentially poison upstream HTTP caches with malicious content. The vulnerability is fixed in Squid version 7.6.