Skip to main content
VulnerabilityPublished

CVE-2025-8267: ssrfcheck · SSRF Bypass Caused by Failure to Classify Reserved IP Address Space as Invalid

Affects ssrfcheckSource GCVE Database

0
Authoritative record:CVE-2025-8267· High 8.8

Public exploit available · CVSS 8.8 High : upgrade to 1.2.0 as a priority.

Data as of 27 Oct 2026, 01:49 UTC

CVSS 4.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ssrfcheck to 1.2.0.

Affected software

ProductAffectedFixed in
npmssrfcheckAffected
  • <1.2.0
Fixed in
  • 1.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in ssrfcheck version 1.2.0 that corrects the denylist to include the reserved multicast IP address space. Users should upgrade to version 1.2.0 or later to mitigate this vulnerability. No additional action is required beyond applying the official fix.

Description

The ssrfcheck npm package has a Server-Side Request Forgery (SSRF) bypass vulnerability due to its failure to classify the reserved multicast IP address space 224.0.0.0/4 as invalid. This incomplete denylist allows URLs pointing to these reserved IPs to be incorrectly considered safe, potentially enabling SSRF attacks. All versions up to 1.1.1 are affected. A fix is available in version 1.2.0.

References

Community reviews

Loading reviews…