CVE-2026-48817: Starlette · Arbitrary HTTP method dispatched to `HTTPEndpoint` attributes via `getattr`
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.21.1_8 when convenient.
Data as of 30 Oct 2026, 08:16 UTC
- Patch
- Available – fixed in 0.21.1_8
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.21.1_8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate this vulnerability, always register HTTPEndpoint subclasses with an explicit methods= argument listing only the supported HTTP verbs. This ensures that unsupported methods are rejected with a 405 Method Not Allowed response before reaching the endpoint, preventing invocation of internal attributes via non-standard HTTP methods. A patch is available in Starlette version 0.21.1_8, which should be applied to affected deployments.
Description
Starlette's HTTPEndpoint dispatches HTTP methods by lowercasing the method name and using getattr without restricting to known HTTP verbs. If an HTTPEndpoint subclass is registered without specifying allowed methods, non-standard HTTP methods can invoke internal attributes as handlers, potentially bypassing authorization. This affects Starlette versions >=0.11.9 and <0.21.1_8 and frameworks built on it like FastAPI. The vulnerability is medium severity with a CVSS score of 5.3.