CVE-2026-78134: strongSwan 4.5.0 through 6.0.7 has Incorrect Access Control in the eap-ttls and eap-peap plugins because there can be a missing or mismatched inner
Affects strongswanSource GCVE Database
Not known to be exploited · CVSS 7.1 High · fixed in 5.9.5-2ubuntu2.8 : patch strongswan soon.
Data as of 5 Nov 2026, 23:24 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.5-2ubuntu2.8, 5.9.13-2ubuntu4.24.04.5, 6.0.4-1ubuntu3.2
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:LExploitation evidence
Disclosed: evidence found.
CVE published 7 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.
What to do
Upgrade the Ubuntu strongswan to 5.9.5-2ubuntu2.8 (package) or 5.9.13-2ubuntu4.24.04.5 (package) or 6.0.4-1ubuntu3.2 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro FIPS-preview 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-preview/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro FIPS-updates 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-updates/jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released by Ubuntu. Users should update strongSwan to the patched versions provided in the Ubuntu security notice USN-8789-1. Specifically, upgrade to at least version 5.9.5-2ubuntu2.8 for Ubuntu 22.04 LTS, 5.9.13-2ubuntu4.24.04.5 for Ubuntu 24.04 LTS, or 6.0.4-1ubuntu3.2 for Ubuntu 26.04 LTS. Applying these updates will remediate the vulnerability.
Description
strongSwan versions 4.5.0 through 6.0.7 contain an incorrect access control vulnerability in the eap-ttls and eap-peap plugins due to missing or mismatched inner EAP identities. This flaw could allow an authenticated user to bypass authentication. The vulnerability has a CVSS score of 7.1 (medium severity). Official patches addressing this issue are available in updated strongSwan packages for multiple Ubuntu LTS releases.