CVE-2026-78132: strongSwan 5.1.3 through 6.0.7 has an infinite loop in the x509 plugin's attribute certificate parser for ietfAttrSyntax
Affects strongswanSource GCVE Database
Not known to be exploited · CVSS 7.5 High · fixed in 5.9.5-2ubuntu2.8 : patch strongswan soon.
Data as of 5 Nov 2026, 00:01 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 28% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.5-2ubuntu2.8, 5.9.13-2ubuntu4.24.04.5, 6.0.4-1ubuntu3.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Upgrade the Ubuntu strongswan to 5.9.5-2ubuntu2.8 (package) or 5.9.13-2ubuntu4.24.04.5 (package) or 6.0.4-1ubuntu3.2 (package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=resoluteOther threats | Affected
| Fixed in
|
Ubuntu 24.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro FIPS-preview 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-preview/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro FIPS-updates 22.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=fips-updates/jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSstrongswanpkg:deb/ubuntu/strongswan?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and can be applied by updating strongSwan to the patched versions provided by Ubuntu security notices, specifically versions 6.0.4-1ubuntu3.2 for Ubuntu 26.04 LTS, 5.9.13-2ubuntu4.24.04.5 for Ubuntu 24.04 LTS, and 5.9.5-2ubuntu2.8 for Ubuntu 22.04 LTS. Applying these official updates will remediate the vulnerability. Standard system updates are sufficient to address this issue.
Description
strongSwan versions 5.1.3 through 6.0.7 contain an infinite loop vulnerability in the x509 plugin's attribute certificate parser when processing ietfAttrSyntax values. This flaw can be triggered remotely to cause the software to consume excessive resources, resulting in a denial of service condition. The vulnerability has a CVSS 3.1 score of 7.5, indicating a medium severity impact. Official patches addressing this issue are available in updated Ubuntu package versions.