Skip to main content
VulnerabilityPublished Updated

CVE-2026-54606: SunEditor Embed Plugin has DOM XSS via External Script Element After Iframe Embed

Affects suneditorSource GCVE Database

0
Compare
Authoritative record:CVE-2026-54606· High 8.5

Not known to be exploited · CVSS 8.5 High : upgrade to 3.1.4 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade suneditor to 3.1.4.

Affected software

ProductAffectedFixed in
npmsuneditorAffected
  • >=3.0.0 <3.1.4
Fixed in
  • 3.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in SunEditor version 3.1.4 that fixes this issue. Users should upgrade to version 3.1.4 or later. The vendor recommends not recreating or appending script elements from user-controlled embed HTML. A minimal mitigation is to skip processing <script> elements entirely. A stronger fix involves allowing only expected embed elements like iframe or blockquote, sanitizing their attributes, and discarding all other sibling elements. No additional action is required if the upgrade is applied.

Description

A DOM-based Cross-Site Scripting (XSS) vulnerability exists in the SunEditor Embed plugin versions 3.0.0 up to but not including 3.1.4. The vulnerability arises when an attacker includes an external script element after an iframe embed, bypassing the plugin's sanitization and causing the script to execute in the context of the editor page. This can lead to arbitrary JavaScript execution when malicious content is stored or reflected without additional backend sanitization.

References

Community reviews

Loading reviews…