Skip to main content
VulnerabilityPublished Updated

CVE-2024-50343: symfony/symfony · Symfony has an incorrect response from Validator when input ends with `\n`

Affects symfony/symfonySource GCVE Database

0
Compare
Authoritative record:CVE-2024-50343· Low 3.1

Not known to be exploited · CVSS 3.1 Low : upgrade to 5.4.43 when convenient.

Data as of 30 Oct 2026, 02:29 UTC

CVSS 3.1 base score
3.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.13.1
Patch
Available – fixed in 5.4.43, 6.4.11, 7.1.4
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade symfony/symfony and symfony/validator to 5.4.43; symfony/symfony and symfony/validator to 6.4.11; symfony/symfony and symfony/validator to 7.1.4.

Affected software

ProductAffectedFixed in
Packagistsymfony/symfonyAffected
  • <5.4.43
Fixed in
  • 5.4.43
Packagistsymfony/symfonyAffected
  • >=6.0.0 <6.4.11
Fixed in
  • 6.4.11
Packagistsymfony/symfonyAffected
  • >=7.0.0 <7.1.4
Fixed in
  • 7.1.4
Packagistsymfony/validatorAffected
  • <5.4.43
Fixed in
  • 5.4.43
Packagistsymfony/validatorAffected
  • >=6.0.0 <6.4.11
Fixed in
  • 6.4.11
Packagistsymfony/validatorAffected
  • >=7.0.0 <7.1.4
Fixed in
  • 7.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Symfony to version 5.4.43, 6.4.11, 7.1.4 or later where the issue is fixed. The patch adds the 'D' regex modifier to ensure the entire input is matched during validation. No other mitigation is required as the fix addresses the root cause.

Description

CVE-2024-50343 is a vulnerability in the Symfony Validator component where inputs ending with a newline character (\n) can bypass validation rules using regular expressions with the $ metacharacter. This occurs because the Validator did not properly anchor the regex to the end of the input. The issue is fixed by adding the 'D' regex modifier to ensure the entire input is matched. Fixed versions include 5.4.43, 6.4.11, and 7.1.4.

References

Community reviews

Loading reviews…