Skip to main content
CVE-2026-121971VulnerabilityPublished

symfony · Component ScopingHttpClient

Affects symfonySource GCVE Database

0
Compare
Authoritative record:CVE-2026-121971· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 8.1.11 : patch symfony soon.

Data as of 4 Nov 2026, 19:44 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Checkmarx)CVSS 4.08.2
Patch
Available – fixed in 8.1.11, 7.4.23, 6.4.50 +1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade symfony/symfony to 8.1.11, 7.4.23, 6.4.50 or 5.4.56.

Affected software

ProductAffectedFixed in
GitHubsymfony/symfonypkg:github/symfony/symfonyOther threatsAffected
  • <5.4.56 >=5.0.0
  • <6.4.50 >=6.0.0
  • <7.4.23 >=7.0.0
  • <8.1.11 >=8.0.0
Fixed in
  • 5.4.56
  • 6.4.50
  • 7.4.23
  • 8.1.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Symfony versions 5.4.56, 6.4.50, 7.4.23, and 8.1.11. Users should upgrade to these or later versions to resolve the issue. The fix ensures that after resolving a relative URL against the base URI, the scheme and authority are compared to prevent credentials from being sent to a different origin. No additional mitigation steps are necessary if the application is updated to these fixed versions.

Description

A vulnerability in the ScopingHttpClient component of Symfony HttpClient allows credentials from a default scope to be sent to an attacker-controlled server when a network-path reference URL is resolved outside the base URI's origin. This occurs in Symfony versions 5.x prior to 5.4.56, 6.x prior to 6.4.50, 7.x prior to 7.4.23, and 8.x prior to 8.1.11. The issue arises because merged options like auth_bearer or auth_basic are retained even when the resolved URL points to a different origin, potentially exposing sensitive credentials.

References

Community reviews

Loading reviews…