Skip to main content
VulnerabilityPublished Updated

CVE-2025-12060: keras.utils.get_file API

Affects kerasSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · CVSS 8.9 High.

Data as of 4 Nov 2026, 18:25 UTC

CVSS 4.0 base score
8.9High
How severe the flaw is on the 0–10 CVSS scale.
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 20.04 LTSkeraspkg:deb/ubuntu/keras?arch=source&distro=focalOther threatsAffected
  • =2.2.4-1
Fixed in–
Ubuntu 18.04 LTSkeraspkg:deb/ubuntu/keras?arch=source&distro=bionicOther threatsAffected
  • =1.0.7-2
  • =2.1.1-1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Keras to version 3.12 or later, which includes a fix for this vulnerability. Additionally, ensure Python is upgraded to a version that addresses CVE-2025-4517, such as Python 3.13.4. Both upgrades are necessary; upgrading Python alone does not fully mitigate the issue.

Description

The keras.utils.get_file API in Keras is vulnerable to a path traversal attack when used with the extract=true option for tar archives. This occurs because the function uses Python's tarfile.extractall without proper filtering, allowing crafted tar archives with malicious symlinks to write files outside the intended extraction directory. The vulnerability is related to an underlying Python tarfile flaw (CVE-2025-4517). Both Python and Keras require updates to fully mitigate the issue.

References

Community reviews

Loading reviews…