Skip to main content
CVE-2026-109997VulnerabilityPublished

The Ninja Forms – Contact Form Builder with Calculators, Quizzes, Signatures & AI Form Builder plugin for WordPress is

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-109997· High 7.2

Not known to be exploited · CVSS 7.2 High · fixed in 3.15.5 : patch Ninja Forms (WordPress plugin) soon.

Data as of 31 Oct 2026, 07:08 UTC

CVSS 3.1 base score
7.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Wordfence)CVSS 3.17.2
Patch
Available – fixed in 3.15.5
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
kstoverNinja Forms – Contact Form Builder with Calculators, Quizzes, Signatures & AI Form BuilderAffected
  • <=3.15.5
Fixed in–

AI-suggested

A fix is available in versions after 3.15.5. Users should upgrade the Ninja Forms plugin to a version later than 3.15.5 to remediate this vulnerability. Until patched, avoid exposing the vulnerable endpoint to untrusted users or implement additional input validation and output escaping as a temporary measure. Since the nonce check is bypassed, relying solely on nonce validation is insufficient.

Description

The Ninja Forms plugin for WordPress up to version 3.15.5 is vulnerable to stored cross-site scripting (XSS) via the 'formData.extra' parameter. This vulnerability arises from insufficient input sanitization and output escaping, allowing unauthenticated attackers to inject malicious scripts that execute when users access the affected pages. The nonce check intended to prevent unauthorized requests is effectively bypassed due to the nf_ajax_submit endpoint issuing a valid nonce on failure, making exploitation straightforward.

References

Community reviews

Loading reviews…