Skip to main content
CVE-2026-116563VulnerabilityPublished

The Photo Gallery, Sliders, Proofing and Themes – NextGEN Gallery plugin for WordPress is vulnerable to Stored

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-116563· Medium 5.4

Not known to be exploited · CVSS 5.4 Medium.

Data as of 31 Oct 2026, 07:08 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (Wordfence)CVSS 3.15.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
smubPhoto Gallery, Sliders, Proofing and Themes – NextGEN GalleryAffected
  • <=4.5.4
Fixed in–

AI-suggested

Users should verify if a patch or update beyond version 4.5.4 is available from the plugin vendor. Until a fix is applied, administrators should consider disabling the Shutter or Shutter Reloaded lightbox options or restrict comment approvals to trusted users to reduce risk. Monitor the vendor advisory for updates and apply official patches once released.

Description

The NextGEN Gallery WordPress plugin (versions up to and including 4.5.4) contains a stored DOM-based cross-site scripting (XSS) vulnerability via the 'comment' parameter. This vulnerability arises from insufficient input sanitization and output escaping, allowing unauthenticated attackers to inject malicious scripts. Exploitation requires the site to use the Shutter or Shutter Reloaded lightbox and for the injected comment to be approved through WordPress's moderation system before the payload executes for other users.

References

Community reviews

Loading reviews…