The terminal emulator of Apache Guacamole 1.5.5 and older does not properly validate console codes received from
Source GCVE Database
Not known to be exploited · CVSS 6.8 Medium · fixed in 1.6.0 : update Apache Guacamole when convenient.
Data as of 4 Nov 2026, 17:53 UTC
- Patch
- Available – fixed in 1.6.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Mavenorg.apache.guacamole/guacamolepkg:maven/org.apache.guacamole/guacamoleOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users should upgrade Apache Guacamole to version 1.6.0 or later, where this vulnerability has been fixed. No other mitigations or workarounds are specified. Applying the official fix is the recommended remediation.
Description
Apache Guacamole versions 1.5.5 and older contain a vulnerability in the terminal emulator where console codes received from servers via text-based protocols like SSH are not properly validated. This flaw allows a malicious user with access to a text-based connection to execute arbitrary code with the privileges of the guacd process. The issue is fixed in version 1.6.0.