Skip to main content
VulnerabilityPublished Updated

CVE-2026-33762: V5 · go-git missing validation decoding Index v4 files leads to panic

Affects github.com/go-git/go-git/v5Source GCVE Database

0
Compare
Authoritative record:CVE-2026-33762· Low 2.8

Not known to be exploited · CVSS 2.8 Low : upgrade to 5.17.1 when convenient.

Data as of 3 Nov 2026, 00:30 UTC

CVSS 3.1 base score
2.8Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.12.8
Patch
Available – fixed in 5.17.1
CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade github.com/go-git/go-git/v5 to 5.17.1.

Affected software

ProductAffectedFixed in
Gogithub.com/go-git/go-git/v5Affected
  • <5.17.1
Fixed in
  • 5.17.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade go-git to version 5.17.1 or later (including the latest v6 pseudo-version) to mitigate this vulnerability. The patch fixes the validation of the path name prefix length to prevent out-of-bounds slice operations. No other mitigations are indicated.

Description

A vulnerability in go-git's index decoder for Git index format version 4 allows a specially crafted index file to cause a runtime panic due to an out-of-bounds slice operation. This can lead to denial-of-service if the application using go-git does not handle panics. The issue requires write access to the local .git directory to inject the malicious index file. Versions prior to 5.17.1 are affected.

References

Community reviews

Loading reviews…