The Total theme for WordPress is vulnerable to Stored Cross-Site Scripting via post titles in versions up to, and
Source GCVE Database
Not known to be exploited · CVSS 5.4 Medium.
Data as of 27 Oct 2026, 00:55 UTC
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| hashthemesTotal | Affected
| Fixed in– |
AI-suggested
No explicit patch or fix is provided in the available data. Users should upgrade beyond version 2.2.1 if a fixed version is released or apply vendor-provided patches when available. Until then, restrict contributor-level access to trusted users and consider disabling the home blog section or featured images to reduce exposure. Monitor the vendor advisory for official remediation updates.
Description
The Total theme for WordPress versions up to and including 2.2.1 contains a stored cross-site scripting (XSS) vulnerability via post titles. This occurs due to insufficient output escaping when rendering the_title() inside an HTML attribute context in the home blog section template. Authenticated users with contributor-level access or higher can exploit this by publishing a malicious post with a featured image, causing arbitrary scripts to execute when other users view the injected page.