CVE-2026-74049: Tomcat6 · Execution After Redirect (EAR) vulnerability in Apache Tomcat
Affects tomcat6Source GCVE Database
Not known to be exploited · fixed in 11.0.27 : patch tomcat6 soon.
Data as of 28 Oct 2026, 22:28 UTC
Rated by Threat Radar · CVSS not yet scored by NVD
- Patch
- Available – fixed in 11.0.27
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Execution After Redirect (EAR) vulnerability in Apache Tomcat. This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.26, from 10.1.0-M1 through 10.1.60, from 9.0.0.M1 through 9.0.122. The following versions were EOL at the time the CVE was created but are known to be affected: from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other unsupported versions may also be affected. Users are recommended to upgrade to version 11.0.27, 10.1.61, 9.0.123, which fixes the issue.
References
- ubuntu.com/security/CVE-2026-74049 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-74049 (opens in a new tab)
- github.com/apache/tomcat/commit/d7948a090ad3f803d9669c8b8401c39e2f532bb7 (opens in a new tab)
- github.com/apache/tomcat/commit/f8023d833675f00968b89b45639210d3c7dcc95d (opens in a new tab)
- github.com/apache/tomcat/commit/6cd2ec7f60b13f8bd93290993401958502c33211 (opens in a new tab)