Skip to main content
VulnerabilityPublished Updated

CVE-2026-74048: Tomcat6 · Not Failing Securely ('Failing Open') vulnerability in Apache Tomcat

Affects tomcat6Source GCVE Database

0
Authoritative record:CVE-2026-74048· Medium

Not known to be exploited · fixed in 11.0.27 : update tomcat6 when convenient.

Data as of 28 Oct 2026, 22:28 UTC

Severity
Medium

Rated by Threat Radar · CVSS not yet scored by NVD

Patch
Available – fixed in 11.0.27

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threatsAffected
  • 10.1.40-1ubuntu1 – 10.1.57~us1-0ubuntu1
7 affected builds
Fixed in–
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threatsAffected
  • 11.0.18-1 – 11.0.24-1ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threatsAffected
  • =9.0.115-1
  • =9.0.115-1ubuntu1
  • =9.0.118-1
Fixed in–
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threatsAffected
  • 9.0.95-1ubuntu1 – 9.0.118-1~26.04.1
5 affected builds
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

Not Failing Securely ('Failing Open') vulnerability in Apache Tomcat. If the OpenSSLLifecycleListener is configured to use FIPS mode but FIPS activation fails, Tomcat logs and error but continues to use JSSE in non-FIPS mode with the provided configuration. This issue affects Apache Tomcat: from 11.0.0-M14 through 11.0.26, from 10.1.22 through 10.1.60, from 9.0.92 through 9.0.122. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.

References

Community reviews

Loading reviews…