CVE-2026-93446: Tomcat6 · Incomplete cleanup vulnerability in Apache Tomcat could cause TLS 1.3 connections to fail
Affects tomcat6Source GCVE Database
Not known to be exploited · fixed in 11.0.27 : update tomcat6 when convenient.
Data as of 28 Oct 2026, 22:28 UTC
Rated by Threat Radar · CVSS not yet scored by NVD
- Patch
- Available – fixed in 11.0.27
Exploitation evidence
Disclosed: evidence found.
CVE published 20 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10tomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Incomplete cleanup vulnerability in Apache Tomcat could cause TLS 1.3 connections to fail intermittently. This issue affects Apache Tomcat: from 11.0.0-M21 through 11.0.26, from 10.1.25 through 10.1.60, from 9.0.90 through 9.0.122. Users are recommended to upgrade to version 11.0.27, 10.1.61 or 9.0.123, which fix the issue.
References
- ubuntu.com/security/CVE-2026-93446 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-93446 (opens in a new tab)
- github.com/apache/tomcat/commit/e49e0c47ea925ad9442ba933a144ea62433d6a06 (opens in a new tab)
- github.com/apache/tomcat/commit/ccbe01a52a9b255ad98e71b5bed76ed10a099503 (opens in a new tab)
- github.com/apache/tomcat/commit/02166d1c7c32973685734ef132e56eb232605cc5 (opens in a new tab)