CVE-2024-23672: Tomcat7 · Denial of Service via incomplete cleanup vulnerability in Apache Tomcat
Affects tomcat7Source GCVE Database
Not known to be exploited · CVSS 6.3 Medium · fixed in 8.5.39-1ubuntu1~18.04.3+esm5 : update tomcat7 when convenient.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 2.3% chance of exploitation in 30 days – higher than 83% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.5.39-1ubuntu1~18.04.3+esm5, 9.0.16-3ubuntu0.18.04.2+esm4, 9.0.31-1ubuntu0.8 +4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 13 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10tomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=questingOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu 20.04 LTStomcat9pkg:deb/ubuntu/tomcat9?arch=source&distro=focalOther threats | Affected
| Fixed in
|
Ubuntu Pro 18.04 LTStomcat8pkg:deb/ubuntu/tomcat8?arch=source&distro=esm-apps/bionicOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
Denial of Service via incomplete cleanup vulnerability in Apache Tomcat. It was possible for WebSocket clients to keep WebSocket connections open leading to increased resource consumption.This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.0-M16, from 10.1.0-M1 through 10.1.18, from 9.0.0-M1 through 9.0.85, from 8.5.0 through 8.5.98. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M17, 10.1.19, 9.0.86 or 8.5.99 which fix the issue.
References
- ubuntu.com/security/CVE-2024-23672 (opens in a new tab)
- lists.apache.org/thread/cmpswfx6tj4s7x0nxxosvfqs11lvdx2f (opens in a new tab)
- github.com/apache/tomcat/commit/0052b374684b613b0c849899b325ebe334ac6501 (opens in a new tab)
- github.com/apache/tomcat/commit/52d6650e062d880704898d7d8c1b2b7a3efe8068 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2024-23672 (opens in a new tab)
- ubuntu.com/security/notices/USN-7106-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-7562-1 (opens in a new tab)