Skip to main content
VulnerabilityPublished Updated

CVE-2025-55668: Apache Tomcat · session fixation via rewrite valve

Affects tomcatSource GCVE Database

0
Authoritative record:CVE-2025-55668· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · patch available : update tomcat when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 58% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.04 LTStomcat10pkg:deb/ubuntu/tomcat10@10.1.55-1ubuntu2~26.04.1?arch=source&distro=resoluteOther threatsAffected
  • =10.1.40-1ubuntu1
  • =10.1.40-1ubuntu1.26.04.1
  • =10.1.55-1ubuntu2~26.04.1
Fixed in–
Ubuntu 26.04 LTStomcat11pkg:deb/ubuntu/tomcat11@11.0.22-2ubuntu2~26.04.1?arch=source&distro=resoluteOther threatsAffected
  • 11.0.6-1 – 11.0.22-2ubuntu2~26.04.1
6 affected builds
Fixed in–
Ubuntu 25.10tomcat10pkg:deb/ubuntu/tomcat10@10.1.40-1ubuntu1.25.10.1?arch=source&distro=questingOther threatsAffected
  • 10.1.35-1 – 10.1.40-1ubuntu1.25.10.1
4 affected builds
Fixed in–
Ubuntu 25.10tomcat11pkg:deb/ubuntu/tomcat11@11.0.6-1?arch=source&distro=questingOther threatsAffected
  • =11.0.6-1
Fixed in–
Ubuntu Pro 24.04 LTStomcat10pkg:deb/ubuntu/tomcat10@10.1.16-1ubuntu0.1~esm4?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 10.1.10-1 – 10.1.16-1ubuntu0.1~esm4
8 affected builds
Fixed in–
Ubuntu Pro 22.04 LTStomcat9pkg:deb/ubuntu/tomcat9@9.0.58-1ubuntu0.2+esm4?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 9.0.43-3 – 9.0.58-1ubuntu0.2+esm4
14 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available. Users should upgrade affected Apache Tomcat installations to versions 11.0.8, 10.1.42, or 9.0.106 as these versions contain the official fix for this session fixation vulnerability. No additional mitigations are specified by the vendor advisory.

Description

A session fixation vulnerability exists in Apache Tomcat via the rewrite valve. This affects Apache Tomcat versions from 11.0.0 through 11.0.7, 10.1.0 through 10.1.41, and 9.0.0 through 9.0.105, with older end-of-life versions potentially also affected. The issue allows an attacker to fixate a session identifier, potentially leading to unauthorized session access. Fixed versions are 11.0.8, 10.1.42, and 9.0.106.

References

Community reviews

Loading reviews…