CVE-2026-39043: Gst plugins good1.0 · Heap buffer overflow in Matroska demuxer
Affects gst-plugins-good1.0Source GCVE Database
Not known to be exploited · fixed in 1.20.3-0ubuntu1.7 : update gst-plugins-good1.0 when convenient.
Data as of 26 Oct 2026, 16:01 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 1.20.3-0ubuntu1.7, 1.24.2-1ubuntu1.5
Exploitation evidence
Disclosed: evidence found.
CVE published 17 Jun 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the Ubuntu gst-plugins-good1.0 to 1.20.3-0ubuntu1.7 (package) or 1.24.2-1ubuntu1.5 (package).
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 25.10gst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=nobleOther threats | Affected
| Fixed in
|
Ubuntu 22.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra/focalOther threats | Affected
| Fixed in– |
Ubuntu Pro 18.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra/bionicOther threats | Affected
| Fixed in– |
Ubuntu Pro 16.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra-legacy/xenialOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
A heap buffer overflow vulnerability exists in the Matroska demuxer component of gst-plugins-good1.0. This vulnerability affects certain versions of gst-plugins-good1.0 prior to 1.20.3-0ubuntu1.7 and 1.24.2-1ubuntu1.5. No CVSS score or detailed impact information is provided. No known exploits in the wild have been reported. The vulnerability affects multiple Ubuntu LTS and standard releases.