Skip to main content
VulnerabilityPublished Updated

CVE-2026-39044: Gst plugins good1.0 · Integer overflow in WAV parser cue handling

Affects gst-plugins-good1.0Source GCVE Database

0
Compare

Not known to be exploited · fixed in 1.20.3-0ubuntu1.7 : update gst-plugins-good1.0 when convenient.

Data as of 26 Oct 2026, 16:01 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

Patch
Available – fixed in 1.20.3-0ubuntu1.7, 1.24.2-1ubuntu1.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu gst-plugins-good1.0 to 1.20.3-0ubuntu1.7 (package) or 1.24.2-1ubuntu1.5 (package).

Affected software

ProductAffectedFixed in
Ubuntu 25.10gst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=questingOther threatsAffected
  • 1.26.0-1ubuntu2 – 1.26.5-1ubuntu2.3
9 affected builds
Fixed in–
Ubuntu 24.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=nobleOther threatsAffected
  • <1.24.2-1ubuntu1.5
Fixed in
  • 1.24.2-1ubuntu1.5
Ubuntu 22.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=jammyOther threatsAffected
  • <1.20.3-0ubuntu1.7
Fixed in
  • 1.20.3-0ubuntu1.7
Ubuntu Pro 20.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.16.1-1ubuntu1 – 1.16.3-0ubuntu1.3+esm4
12 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.12.3-1ubuntu1 – 1.14.5-0ubuntu1~18.04.3+esm4
14 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSgst-plugins-good1.0pkg:deb/ubuntu/gst-plugins-good1.0?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 1.6.0-1ubuntu1 – 1.8.3-1ubuntu0.5+esm4
19 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in gst-plugins-good1.0 versions 1.20.3-0ubuntu1.7 and later, and 1.24.2-1ubuntu1.5 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No additional vendor advisory content is provided, so check the Ubuntu security advisories for official patch details.

Description

An integer overflow vulnerability exists in the WAV parser cue handling of gst-plugins-good1.0. This flaw affects certain versions of the gst-plugins-good1.0 package on multiple Ubuntu releases. No CVSS score is provided, and no known exploits are reported in the wild. The vulnerability could potentially lead to unexpected behavior when processing WAV files containing crafted cue data.

References

Community reviews

Loading reviews…