Skip to main content
CVE-2026-56362VulnerabilityPublished Updated

ImageMagick before 7.1.2-15 contains a heap-buffer-overflow read vulnerability in GetPixelIndex caused by

Affects imagemagickSource GCVE Database

0
Compare
Authoritative record:CVE-2026-56362· Low 2.1

Not known to be exploited · CVSS 2.1 Low · fixed in 7.1.2 : update imagemagick when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
2.1Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.1
CNA (VulnCheck)CVSS 3.13.3
EPSS
0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 7.1.2
CVSS:4.0/AV:N/AC:H/AT:P/PR:H/UI:N/VC:L/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threatsAffected
  • 8:7.1.2.18+dfsg1-1 – 8:7.1.2.31+dfsg1-1
4 affected builds
Fixed in–
Ubuntu 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.18+dfsg1-1?arch=source&distro=resoluteOther threatsAffected
  • 8:7.1.2.3+dfsg1-1 – 8:7.1.2.18+dfsg1-1
7 affected builds
Fixed in–
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • 8:7.1.2.3+dfsg1-1 – 8:7.1.2.18+dfsg1-1ubuntu0.1~esm4
11 affected builds
Fixed in–
Ubuntu 25.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=questingOther threatsAffected
  • 8:7.1.1.43+dfsg1-1 – 8:7.1.2.3+dfsg1-1ubuntu0.1
5 affected builds
Fixed in–
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm10?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 8:6.9.11.60+dfsg-1.6ubuntu1 – 8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm10
14 affected builds
Fixed in–
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm11?arch=source&distro=esm-apps/jammyOther threatsAffected
  • 8:6.9.11.60+dfsg-1.3 – 8:6.9.11.60+dfsg-1ubuntu1
24 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in ImageMagick version 7.1.2-15 and later. Users should upgrade to this version or later to remediate the vulnerability. Since the vendor advisory is not provided, patch status is inferred from the version information indicating the fix is in 7.1.2-15. No additional mitigation steps are specified.

Description

ImageMagick versions prior to 7.1.2-15 contain a heap-buffer-overflow read vulnerability in the GetPixelIndex function. This flaw is caused by OpenPixelCache updating image channel metadata before pixel cache memory allocation, which can lead to memory and disk allocation failures. The vulnerability affects any writer calling GetPixelIndex and has a medium severity rating with a CVSS score of 4.2.

References

Community reviews

Loading reviews…