Skip to main content
VulnerabilityPublished Updated

CVE-2026-59831: GitHub CLI (gh) is GitHub’s official command line tool

Affects ghSource GCVE Database

0
Compare

Not known to be exploited · CVSS 4.4 Medium · fixed in 2.96.0 : update gh when convenient.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 3.1 base score
4.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.96.0
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10ghpkg:deb/ubuntu/gh?arch=source&distro=stonkingOther threatsAffected
  • =2.46.0-4
Fixed in–
Ubuntu Pro 26.04 LTSghpkg:deb/ubuntu/gh?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • =2.46.0-3
  • =2.46.0-4
  • =2.46.0-4ubuntu0.26.04.1~esm1
Fixed in–
Ubuntu Pro 24.04 LTSghpkg:deb/ubuntu/gh?arch=source&distro=esm-apps/nobleOther threatsAffected
  • 2.27.0+dfsg1-1build1 – 2.45.0-1ubuntu0.3+esm3
18 affected builds
Fixed in–
Ubuntu 22.04 LTSghpkg:deb/ubuntu/gh?arch=source&distro=jammyOther threatsAffected
  • =2.4.0+dfsg1-1
  • =2.4.0+dfsg1-2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade GitHub CLI (gh) to version 2.96.0 or later, where this vulnerability is fixed. No other mitigations are specifically recommended by the vendor advisory.

Description

GitHub CLI (gh) versions 2.10.0 through 2.95.0 contain a vulnerability in the 'gh codespace jupyter' command. This command opens a JupyterLab URL from inside the Codespace without validating that the URL is a loopback HTTP or HTTPS address. An attacker can craft vscode:// or vscode-insiders:// URLs that may be passed to VS Code, potentially enabling command execution. The issue is fixed in version 2.96.0.

References

Community reviews

Loading reviews…