CVE-2026-59947: Composer is a dependency Manager for the PHP language
Affects composerSource GCVE Database
Not known to be exploited · CVSS 4.7 Medium · fixed in 2.2.29 : update composer when convenient.
Data as of 30 Oct 2026, 11:52 UTC
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 1% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.2.29
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10composerpkg:deb/ubuntu/composer?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10composerpkg:deb/ubuntu/composer?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTScomposerpkg:deb/ubuntu/composer?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade Composer to version 2.2.29 or later, or 2.10.2 or later, where this issue is fixed. Avoid running Composer with -vvv verbosity on untrusted systems or where debug output may be exposed until the upgrade is applied.
Description
Composer versions prior to 2.2.29 and 2.10.2 may leak credentials embedded in the username portion of repository or package URLs in debug output when run with very verbose (-vvv) mode. This vulnerability can expose sensitive tokens such as GitHub Personal Access Tokens. The issue is fixed in versions 2.2.29 and 2.10.2.