CVE-2026-61465: ImageMagick before 7.1.2-26 and 6.9.13-51 is missing a check for the allowed memory allocation limit
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium · fixed in 8:6.8.9.9-7ubuntu5.16+esm24 : update imagemagick when convenient.
Data as of 29 Oct 2026, 19:04 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 4.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.3 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8:6.8.9.9-7ubuntu5.16+esm24, 8:6.9.7.4+dfsg-16ubuntu6.15+esm16, 8:6.9.10.23+dfsg-2.1ubuntu11.11+esm14 +3
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.18+dfsg1-1?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available and has been released in multiple updated Ubuntu package versions including 8:6.8.9.9-7ubuntu5.16+esm24 and later. Users should upgrade to these fixed versions or later to mitigate the vulnerability. No additional action is required beyond applying the official patches.
Description
ImageMagick versions before 7.1.2-26 and 6.9.13-51 lack a check for allowed memory allocation limits in matrix-backed operations such as -canny. This flaw allows an attacker to supply a crafted image that causes the software to allocate more memory than permitted by configured policies, leading to denial of service. The issue affects multiple Ubuntu package versions and has been fixed in later releases.
References
- ubuntu.com/security/CVE-2026-61465 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-61465 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-rvhp-75f6-9jqh (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-26-memory-allocation-policy-bypass (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-2 (opens in a new tab)