Skip to main content
VulnerabilityPublished Updated

CVE-2026-61857: ImageMagick before 7.1.2-26 contains a heap use-after-free vulnerability caused by missing null check

Affects imagemagickSource GCVE Database

0
Compare
Authoritative record:CVE-2026-61857· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium · fixed in 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14 : update imagemagick when convenient.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.3
CNA (VulnCheck)CVSS 3.13.7
EPSS
0.2% chance of exploitation in 30 days – higher than 18% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14, 8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm13, 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade the Ubuntu imagemagick to 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14 (package) or 8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm13 (package) or 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2 (package).

Affected software

ProductAffectedFixed in
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threatsAffected
  • 8:7.1.2.18+dfsg1-1 – 8:7.1.2.31+dfsg1-1
4 affected builds
Fixed in–
Ubuntu 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.18+dfsg1-1?arch=source&distro=resoluteOther threatsAffected
  • 8:7.1.2.3+dfsg1-1 – 8:7.1.2.18+dfsg1-1
7 affected builds
Fixed in–
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threatsAffected
  • <8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
Fixed in
  • 8:7.1.2.18+dfsg1-1ubuntu0.1~esm2
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threatsAffected
  • <8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm13
Fixed in
  • 8:6.9.12.98+dfsg1-5.2ubuntu0.1~esm13
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14
  • =8:6.9.11.60+dfsg-1ubuntu1
Fixed in
  • 8:6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.10.23+dfsg-2.1ubuntu11.11+esm11?arch=source&distro=esm-apps/focalOther threatsAffected
  • 8:6.9.10.23+dfsg-2.1ubuntu3 – 8:6.9.10.23+dfsg-2.1ubuntu11.11+esm11
31 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available for this vulnerability. Users and administrators should upgrade ImageMagick to one of the fixed versions: 6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14, 6.9.12.98+dfsg1-5.2ubuntu0.1~esm13, or 7.1.2.18+dfsg1-1ubuntu0.1~esm2. The vendor advisory from Ubuntu confirms these fixes and recommends applying them to mitigate the issue.

Description

ImageMagick versions prior to 7.1.2-26 contain a heap use-after-free vulnerability due to a missing null check when parsing XMP profiles. This flaw can be triggered by maliciously crafted image files containing specially crafted XMP data, potentially causing application crashes (denial of service). The vulnerability has a CVSS score of 7.5 and is classified as medium severity. Fixes are available in later versions including 6.9.11.60+dfsg-1.3ubuntu0.22.04.5+esm14, 6.9.12.98+dfsg1-5.2ubuntu0.1~esm13, and 7.1.2.18+dfsg1-1ubuntu0.1~esm2. No known exploits in the wild have been reported. The vendor advisory confirms the availability of patches and recommends updating to fixed versions.

References

Community reviews

Loading reviews…