CVE-2026-61858: ImageMagick before 7.1.2-26 contains a policy bypass vulnerability in the APNG encoder and external
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 4.8 Medium · fixed in 7.1.2 : update imagemagick when convenient.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 4.8 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 3.3 |
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 15% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.1.2
CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.18+dfsg1-1?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in– |
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in– |
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:6.9.10.23+dfsg-2.1ubuntu11.11+esm11?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in ImageMagick version 7.1.2-26 and later. Users should upgrade to this version or newer to remediate the vulnerability. Since the vulnerability is due to missing validation checks, applying the official patch will address the issue. No alternative mitigations are specified.
Description
ImageMagick versions prior to 7.1.2-26 contain a policy bypass vulnerability in the APNG encoder and external delegates due to missing validation checks. This flaw allows attackers to write files to disallowed paths by circumventing configured policy restrictions during the APNG encoding process. The vulnerability has a medium severity with a CVSS score of 5.3 and does not impact confidentiality or availability but can affect integrity.
References
- ubuntu.com/security/CVE-2026-61858 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-61858 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-v3j6-27vc-7pw2 (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-26-policy-bypass-via-apng-encoder (opens in a new tab)