CVE-2026-61870: ImageMagick before 7.1.2-26 contains a memory leak vulnerability in the VIFF encoder when memory
Affects imagemagickSource GCVE Database
Not known to be exploited · CVSS 2.1 Low · fixed in 8:6.7.7.10-6ubuntu3.13+esm25 : update imagemagick when convenient.
Data as of 30 Oct 2026, 11:52 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.1 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 2.9 |
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 8% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8:6.7.7.10-6ubuntu3.13+esm25, 8:6.8.9.9-7ubuntu5.16+esm24, 8:6.9.7.4+dfsg-16ubuntu6.15+esm16 +4
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 11 Jul 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10imagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick@8:7.1.2.18+dfsg1-1?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu Pro 26.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/resoluteOther threats | Affected
| Fixed in
|
Ubuntu Pro 24.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro 22.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/jammyOther threats | Affected
| Fixed in
|
Ubuntu Pro 20.04 LTSimagemagickpkg:deb/ubuntu/imagemagick?arch=source&distro=esm-apps/focalOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. Fixed versions include Ubuntu package releases 8:6.7.7.10-6ubuntu3.13+esm25 and later. Users should upgrade to these fixed versions or newer to remediate the vulnerability.
Description
ImageMagick versions before 7.1.2-26 contain a memory leak vulnerability in the VIFF image encoder triggered when memory allocation fails. This flaw allows attackers to cause denial of service by exhausting available memory with specially crafted VIFF images. The vulnerability affects multiple Ubuntu package versions of ImageMagick. A fix is available in newer package releases.
References
- ubuntu.com/security/CVE-2026-61870 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-61870 (opens in a new tab)
- github.com/ImageMagick/ImageMagick/security/advisories/GHSA-m596-67p7-69wh (opens in a new tab)
- vulncheck.com/advisories/imagemagick-before-26-memory-leak-via-viff-encoder (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/opensuse-su-2026_21401-1.json (opens in a new tab)
- bugzilla.suse.com/1271293 (opens in a new tab)
- suse.com/security/cve/CVE-2026-61870/ (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-1 (opens in a new tab)
- ubuntu.com/security/notices/USN-8739-2 (opens in a new tab)