Skip to main content
VulnerabilityPublished Updated

CVE-2026-120135: Apache Thrift Java bindings · Uncontrolled Recursion Vulnerability

Affects thriftSource GCVE Database

0
Compare
Authoritative record:CVE-2026-120135· High 8.2

Not known to be exploited · CVSS 8.2 High · fixed in 0.24.0 : patch thrift soon.

Data as of 5 Nov 2026, 12:47 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.08.2
Patch
Available – fixed in 0.24.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 31 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10thriftpkg:deb/ubuntu/thrift?arch=source&distro=stonkingOther threatsAffected
  • =0.22.0-3ubuntu1
  • =0.23.0-3
  • =0.23.0-3ubuntu1
Fixed in–
Ubuntu 26.04 LTSthriftpkg:deb/ubuntu/thrift?arch=source&distro=resoluteOther threatsAffected
  • =0.19.0-4build1
  • =0.22.0-3
  • =0.22.0-3ubuntu1
Fixed in–
Ubuntu 24.04 LTSthriftpkg:deb/ubuntu/thrift?arch=source&distro=nobleOther threatsAffected
  • 0.17.0-4 – 0.19.0-2build1
5 affected builds
Fixed in–
Ubuntu 22.04 LTSthriftpkg:deb/ubuntu/thrift?arch=source&distro=jammyOther threatsAffected
  • 0.13.0-6ubuntu1 – 0.16.0-2
5 affected builds
Fixed in–
Ubuntu 20.04 LTSthriftpkg:deb/ubuntu/thrift?arch=source&distro=focalOther threatsAffected
  • =0.11.0-6
  • =0.13.0-2build1
  • =0.13.0-2build2
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade Apache Thrift to version 0.24.0 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

An uncontrolled recursion vulnerability exists in the Apache Thrift Java bindings affecting versions before 0.24.0. This flaw can lead to high-impact consequences if exploited. The issue is resolved in Apache Thrift version 0.24.0, and users are advised to upgrade to this version to mitigate the risk.

References

Community reviews

Loading reviews…